FLEXnet Licensing error:-125,147: A PACKAGE component must be specified


You can almost always safely ignore this error. In LMTOOLS, Perform Diagnostics reports this error because LMTOOLS does not fully understand the new “package” license file format.

In a license file, a PACKAGE is a container for the actual licenses. LMTOOLS incorrectly treats the PACKAGE as a license, so you get an error (and in the Perform Status Enquiry output, you get what looks like double the actual number of licenses, because the packages are treated like actual licenses).

When I’m helping customers, I rarely use Perform Diagnostics. For general license troubleshooting, I prefer to use Perform Status Enquiry (Server Status tab).

Read on only if you’re interested in the gory details of the .lic file…

For example, in a license file you have this:

PACKAGE 78900SFTIMA_F adskflex 1.000 COMPONENTS="84100SFTIMA_2010_0F \
    78800SFTIMA_7_5F" OPTIONS=SUITE SUPERSEDE ISSUED=12-Aug-2009 \
    SIGN="12B2 E17F D7D2 604D AF1E 76A4 688B 89CB 6DBD 5597 16B6 \
    4116 E855 ABB0 D2F9 01AE EDB9 7B92 9BF8 D829 EF4D E6B7 0EBD \
    F95A 7752 0C2F 95DB F9D9 0B9A 27CE" SIGN2="1276 FD9E A12B 86D7 \
    B9E5 F193 9CB0 8528 21A6 101C 949F 4CAD 4666 0D72 6D9D 022F \
    5EC7 5534 4E20 A90F B6CB D5D4 F4BF 5067 1E6A DCE5 77A2 5EF0 \
    8F36 D066"
  • 78900SFTIMA_F is the package.
  • 84100SFTIMA_2010_0F is the Softimage 2010 license.
  • 78800SFTIMA_7_5F is the Softimage 7.5 license.

In the Perform Diagnostics output, you get an error for the package:

"78900SFTIMA_F" v1.000, vendor: adskflex
  License server: mtl-example
  floating license  starts: 1-jan-1990,   expires: 12-aug-2010
  Requests from the same USER/HOST do not consume a new license

This license cannot be checked out because:
A PACKAGE component must be specified.
Feature:       78900SFTIMA_F
License path:  C:\Program Files\Autodesk Network License Manager\SFTIMA2010.lic;
FLEXnet Licensing error:-125,147

But for the actual licenses (aka features), you get this:

This license can be checked out
-----------------------------------------------------
"84100SFTIMA_2010_0F" v1.000, vendor: adskflex

3 thoughts on “FLEXnet Licensing error:-125,147: A PACKAGE component must be specified

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s