Running Softimage on other distros like Ubuntu, Kubuntu, Pardus, and Gentoo


Here’s a workaround for running Softimage on other distros like Ubuntu, Kubuntu, Pardus, and Gentoo.
On these distros, some users have noticed problems with images (cannot browse for images, or even create noicon clips). Or Softimage can create and even save scenes, but crashes when you open a scene.

One of the Softimage developers believes he may have tracked down the source of this problem. The Softimage library libdsprsr.so has a dependency on libtiff and libjpeg. If either of these is missing, then the Softimage library fails to register correctly (during the install), but unfortunately no error is reported.

As a workaround you can try the following steps:

  1. Open your Softimage shell and source the .xsi file
  2. cd to the “Application\bin” folder
  3. Run cmdreg libdsprsr.so
  4. If you get an error, then you have this problem, so we can try to fix it. Now run ldd libdsprsr.so
  5. You should see that 1 (or more) libraries are missing – most likely libtiff and/or libjpeg.
  6. Install the required package(s) to get the missing libraries and then run the cmdreg again: cmdreg libdsprsr.so
  7. It should register now and all the problems with image nodes will be gone.
  8. If you have other strange problem you can ensure that all the Softimage libraries are registered correctly, by re-registering them all by running cmdreg -f XSICOMDLLs.lst
  9. If you have any errors, run the steps above checking the failing library with ldd to see which libraries are missing.

Hat tip: Sean Donnelly

8 thoughts on “Running Softimage on other distros like Ubuntu, Kubuntu, Pardus, and Gentoo

    • Hi

      I was able to run that in ubuntu. However, I’m unable to load any images or textures since I got error that the file doesn’t exist.

      Still trying to get it working…

  1. Hi,

    We’re trying to launch XSI commercial 2012 SP1 on new KUbuntu 12.04 with no luck so far…

    Very helpful article! Without it, I would have missed the cmdreg test… Just ldd indicated that libs loading without errors.

    I corrected the missing link for libtiff.so. But no change… I saw that may libcg.so and libCgGl.so could conflict, I tried to rename XSI’ libs to be sure that the system’ libs will be taken, no change.

    Apps crashes in segmentation fault when going into sched_yield() function?
    We tried to delete all tmp files, all .mw folder, all user’s files…
    We tried to launch XSI as root, user with admin rights, simple user…
    We verified that /var/tmp is full access rights…
    Strangely, XSI windows starts with logo but after we just got white squares whereas floating menu or menu decorations should be visible. Then crash.
    Other point: the first blank “scene” is marked “[read only]” in the title windows???

    Does anyone has managed to launch XSI 2012 SP1 on Ubuntu 12.04?
    If yes: HOW?!?

    Cheers
    ————————————————————————-
    With strace it’s always end in the same scenario:
    stat(“/home/user/Autodesk/Softimage_2012_SP1/_DSRTL.MTT”, {st_mode=S_IFREG|0664, st_size=22162, …}) = 0
    chmod(“/home/user/Autodesk/Softimage_2012_SP1/DSRTL.MTT”, 0100664) = 0
    lstat(“/home/user/Autodesk/Softimage_2012_SP1/vinst46d23992bec611e1eede59a8.bt”, {st_mode=S_IFREG|0664, st_size=4868, …}) = 0
    close(46) = 0
    write(31, “Failed to save scene before syst”…, 43) = 43
    write(31, “\n”, 1) = 1
    lseek(60, 1024, SEEK_SET) = 1024
    write(60, “Root Entry”…, 512) = 512
    close(60) = 0
    stat(“/var/tmp/XSI_Temp_358/ViewSetup.DSViewSettings”, {st_mode=S_IFREG|0664, st_size=1536, …}) = 0
    access(“/var/tmp/XSI_Temp_358/ViewSetup.DSViewSettings”, W_OK) = 0
    unlink(“/var/tmp/XSI_Temp_358/ViewSetup.DSViewSettings”) = 0
    munmap(0x7f2c60044000, 16384) = 0
    unlink(“/var/tmp/Mw_user/F94B9DDC2F2A530B72986955E99C6D4C.1316710.tmp.53”) = 0
    munmap(0x7f2c1f7a4000, 2097152) = 0
    unlink(“/var/tmp/Mw_user/F94B9DDC2F2A530B72986955E99C6D4C.1316710.tmp.52”) = 0
    lseek(61, 1024, SEEK_SET) = 1024
    write(61, “Root Entry”…, 512) = 512
    close(61) = 0
    stat(“/var/tmp/XSI_Temp_358/ViewSetupSequence.DSViewSettings”, {st_mode=S_IFREG|0664, st_size=1536, …}) = 0
    access(“/var/tmp/XSI_Temp_358/ViewSetupSequence.DSViewSettings”, W_OK) = 0
    unlink(“/var/tmp/XSI_Temp_358/ViewSetupSequence.DSViewSettings”) = 0
    munmap(0x7f2c60040000, 16384) = 0
    unlink(“/var/tmp/Mw_user/F94B9DDC2F2A530B72986955E99C6D4C.1316710.tmp.56”) = 0
    munmap(0x7f2c307b4000, 2097152) = 0
    unlink(“/var/tmp/Mw_user/F94B9DDC2F2A530B72986955E99C6D4C.1316710.tmp.55”) = 0
    sched_yield() = 0
    — SIGSEGV (Segmentation fault) @ 0 (0) —
    +++ killed by SIGSEGV (core dumped) +++

  2. Pingback: FINALLY!! Softimage running on Ubuntu! | GetSetData

Leave a Reply to ozcar Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s