The case of satellite rendering not working in 2011 SAP on 32-bit Windows XP


In this case, a customer was trying to use 64-bit Windows satellites from a 32-bit Windows XP master computer. The problem: it didn’t work. The mental ray diagnostic messages don’t show any usage of the satellites when he rendered on the master computer.

The customer double-checked that ray3hosts had the right computer names and ports, that the raysat service was running on the master and the satellites, and that telnet could connect to the raysat ports. In addition, the customer tried using the 32-bit XP machine as a satellite, and that did work. So it looked to the customer like maybe 32-bit 2011 SAP couldn’t use 64-bit satellites.

I set up a 32-bit Windows XP master with some 64-bit Windows 7 satellites, and sure enough it didn’t work. In addition to checking the mental ray diagnostics on the master, I also run Process Monitor on the satellites to check for raysat activity, and I wasn’t seeing anything.

After double-checking everything again, I tried using WireShark, a network protocol analyzer, on the master to see if Softimage was even trying to connect to the satellite.

I didn’t see any outgoing TCP traffic to the satellite, so I decided to use Process Monitor on the master to check whether Softimage was loading .ray3hosts. And sure enough, it wasn’t.

So I used Process Monitor to check where UserTools was creating .ray3hosts, and it turned out that on Windows XP, UserTools creates the .ray3hosts file in the “wrong” place:

C:\Documents and Settings\blairs\Autodesk\Softimage_2011_Subscription_Advantage_Pack\.ray3hosts

It’s the wrong place because Softimage looks for .ray3hosts here:

C:\users\blairs\Autodesk\Softimage_2011_Subscription_Advantage_Pack\.ray3hosts

Some workarounds:

  • Manually copy the .ray3hosts file to the right place
  • Edit setenv.bat and set MI_RAY_HOSTSFILE to point to the folder used by UserTools
  • Start UserTools from a Softimage command prompt, so it picks up XSI_USERROOT from the environment set by setenv.bat

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s